Home Page Forums Community International Develop OpenWebNet F455 not executing OWN commands

OpenWebNet
F455 not executing OWN commands

This topic contains 3 replies, has 3 voices, and was last updated by  sxpertle 08/07/2018 at 07:31.

0
3
1282
  • Verified

    So, we just got an F455 for the office to try it out (we’ve only used F454, F452V and MH200N as gateways), we took it out of its box, made all the necessary initial configuration (pressed the button for over 20secs so it would default to DHCP, changed admin password, etc), we can access it’s web setup just fine, but when I try to send commands to it via putty, the session closes abruptly. Here’s what I do:

    – Open Putty

    – Load the telnet preset I use for bticino gateways (works perfectly with the gateways we’ve used before)

    – As soon as I start the session I get an ACK command, so everything’s good there.

    – I type the open frame command “*99*9##” and when I hit ctrl+d to send the command the session closes, first time I’ve seen that happen with the gateways we’ve used (F454, MH200N and F452V).

    I’ve tried this same procedure several times, and still nothing…

    I really need your help with this issue. Thanks in advanced.




    User
    dchramcow
    Role
    System Integrator
    52 posts
    Verified

    hallo,

    why do you sue “*99*9##” ?

    the right command is “*99*0##” for command socket and “*99*1##” for monitor socket

    Lorenzo




    User
    BT_Lorenzo
    Role
    Community Manager
    7365 posts
    Verified

    Thanks for the reply Lorenzo.

    I got the *99*9## out of the OWN introduction document: http://oi68.tinypic.com/261kp5g.jpg

    Just tried with *99*0## and it started working correctly.

    One thing I wanted to ask you guys is if it was possible to disable the 30 seconds timeout it has for TCP/IP connections. If I start Putty and connect to the F455, it closes by itself after 30 seconds of inactivity, that doesn’t go well when trying to control MyHome devices via an automation controller.




    User
    dchramcow
    Role
    System Integrator
    52 posts
    Verified

    you can send dummy commands every 25 seconds, or just re-open the connection whenever you have a sequence of commands to send




    User
    sxpertle
    Role
    System Integrator
    605 posts
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.